Problem with Rega Aria Phono Stage

Jun 18, 2020
32
8
8
57
#1
I currently run a Rega P8 with Aphetta 3 MC cartridge. I have been using a Rega Aria Phonostage and it has recently begun to cause a low level buzz in my speakers once it warms up. When I first power it on it is dead silent, but after playing an album or two you can hear a low level buzz in the speakers when not playing a record. If I unplug the turntable from the phono stage the buzzing continues. Does anyone have an idea as to what could cause this? Also, if I am going to upgrade what would you recommend for a MC phonostage to go with the Rega TT in the $2k-$4k range?
 

About us

  • What’s Best Forum is THE forum for high-end audio, product reviews, advice and sharing experiences on the best of everything else. A place where audiophiles and audio companies discuss existing and new audio products, music servers, music streamers and computer audio, digital to audio converters, turntables, phono stages, cartridges, reel to reel, speakers, headphones, tube amplifiers and solid state amplification. Founded in 2010 What's Best Forum invites intelligent and courteous people of all interests and backgrounds to describe and discuss the best of everything. From beginners to life-long hobbyists to industry professionals we enjoy learning about new things and meeting new people and participating in spirited debates.

Quick Navigation

User Menu

Steve Williams
Site Founder | Site Owner | Administrator
Ron Resnick
Site Co-Owner | Administrator
Julian (The Fixer)
Website Build | Marketing Managersing